SubHero - API is back up – Incident details

All systems operational

API is back up

Resolved
Major outage
Started 13 days agoLasted about 3 hours

Affected

API

Operational from 10:24 PM to 10:24 PM, Major outage from 10:24 PM to 1:44 AM

Updates
  • Postmortem
    Postmortem

    Summary
    Between May 20, 2026 06:24 UTC and 09:44 UTC (3h 20m), SubHero's API and background workers were unavailable. Translation, transcription, and any feature that talks to our backend returned errors. The Cloudflare-hosted marketing site, in-browser subtitle editor tools, and Supabase auth were unaffected.

    Root cause
    Our backend (FastAPI + Celery workers) is hosted on Railway, which runs on Google Cloud Platform. During this window, GCP suspended Railway's account, taking Railway's entire infrastructure offline. Every service hosted on Railway — ours included — went down with it. This was an upstream provider issue outside our control.

    Resolution
    Service was restored automatically once Railway's account was reinstated and their platform recovered. No data was lost; in-flight tasks resumed when workers came back online.

    Apologies to everyone affected. — SubHero team

  • Resolved
    Resolved
    API is back up. This incident was automatically resolved by Instatus monitoring.
  • Investigating
    Investigating
    API is down at the moment. This incident was automatically created by Instatus monitoring.